Legacy array/generator comprehension syntaxes have been removed

Published: | Categories: JavaScript

Description

The support for the legacy, non-standard array comprehensions and generator comprehensions, introduced with JavaScript 1.7 and 1.8 respectively, has been removed with Firefox 46. Each new syntax proposed for ECMAScript is available since Firefox 30, though it’s still uncertain whether those will be standardized.

Update: The initial draft of this document said array/generator comprehensions would be removed, but the bug has been updated to only remove the legacy syntaxes for now.

Update 2: The newer syntaxes couldn’t be standardized either, and therefore, the implementation has been removed with Firefox 58.

References