let statement no longer requires explicit JavaScript version

Published: | Categories: JavaScript

Description

Previously, the let statement required an explicit JavaScript version, specifically 1.7 or later, on the <script> element like this:

<script type="application/javascript;version=1.7"></script>

The let statement has been standardized in ECMAScript 2015 (ES6) and therefore such a version is no longer required to use it. This change should be backward compatible, but let us know if you find any issues (pun intended). The non-standard JavaScript versioning will be completely retired in the near future.

References