Affecting RC4 support has been deprecated

Published: | Categories: Privacy & Security

Description

The RC4 cipher suites are now considered insecure. RC4 is no longer offered in the first TLS handshakes, and the security UI in Firefox no longer calls it “high-grade encryption” but rather would say “encryption is not strong enough”. The RC4 support will completely be removed from Mozilla products in the near future. Webmasters should upgrade their servers as soon as possible to utlize stronger cipher suites.

Update: The RC4 support has been disabled with Firefox 44.

References